Judge Environment

Hardware

i3-8100T or better

OS

Linux 5.2.9 or later

Distribution

Arch Linux

Compilers / Interpreters

C/C++: GNU Compiler Collections 9.1.0 or later
Java: OpenJDK 12.0.2 or later
Kotlin: 1.3.41 or later (on OpenJDK JRE 12.0.2 or later)
Python 3: 3.7.4 (CPython)
Python 2: 2.7.13 (PyPy 7.1.1)

Options for Compiler or Run-time Environment

C++:
g++ -std=c++17 -x c++ -Wall -O2 -static -pipe

C:
gcc -std=c18 -x c -Wall -O2 -static -pipe YOUR_SOURCE_CODE.c -lm

Java:
javac -encoding UTF-8
java -Dfile.encoding=UTF-8 -XX:+UseSerialGC

Kotlin:
kotlinc -jvm-target 12
kotlin -Dfile.encoding=UTF-8 -J-XX:+UseSerialG

(Visited 286 times, 1 visits today)